You are here

hg308 not runnin right

GDAY all hoping someone may be able to help.I recently got my hg ute on the road (NOVEMBER) and was running nice untill i had the trans rebuilt,engine now runs real rough from idle to 2000rpm after 2000 its fine,when at traffic lights it stalls ,this engine is a 308 which has now done 7000mls.I had this engine rebuilt for gas and it is running a 650 holley vac secs,carb is now the only thing that has not been rebuilt.I run this car on gas most of the time.I have replaced leads cap plugs and rotor ,,,STILL runs rough,is it possible the coil might be my problem ??? ANY SUGGESTIONS APPRECIATED !CHEERS MATTYT..

Model: 
Topic: 
Engine: 
Section: 

Comments

Is the transmission an auto?

If so, maybe there is something wrong with the vacuum line for the modulator?

Cheers
Dave

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Which trans are you using? If it is one that used vacuum modulation, check that the trans repairers have correctly fitted the vacuum pipe to the engine.
A big air leak into the manifold will cause your problem.

Rod

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Gas Has been known to give performance issues.

Does the engine perform the same on petrol?

From my own experience see if the performance changes after the next refill.Wax does fill up in the converters. A a clean out of the converter might also be required.

Just a thought....

Regards Rockett

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.
  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.