You are here

Power steering pump woes

Hi all

just rebuilt the power steering pump on my HX Premier wagon (253) and fitted a new seal kit as per instructions and some post on this site.

The pump has been refitted and system bled of air (I jacked the car and turned lock to lock a few times - heard the air bubble out) but I have no pump pressure and running it to temp only results in 'manual' steering and no pump / pressure assistance. Belt tension is OK and the reserviour has ample new fluid in it.

I've taken the pump off and re-did the whole process but nothing. No leaks which is great but no pump pressure.

Any ideas?

Model: 
Topic: 

Comments

Pay close attention to the valve and spring assy on the pressure side. Real easy to put bits in wrong way round.

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Q-ball.

"Clay is for racing on,Tar is how you get there!!"
[http://gallery.oldho...|My Shed]
3401

Cheers Q Ball. I installed this part with spring first, then value (flat end facing out) and the pressure union bolt ( thru the can - with new O ring) last, which is right.

Is there a 'top side' to the bottom thrust plate? Obviously it goes in face up, but does it matter which dowel pin hole you put top or bottom towards the pressure port?

Your pics & instructions were very helpful

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.
  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.