You are here

ANYONE converted their 308 to a 304 NEED HELP

I have followed the below instructions basically spot on.... I have converted my 308 to a 304 top end on my HQ... I used a VS top end, a VN v8 computer/loom and modified the distributor plug to suit VS (signal,12v and ground wires simple).. Im running a Bosch 044 fuel pump with a VL turbo fuel filter inline.

-- INSTRUCTIONS I FOLLOWED....

"Wiring instruction for a injected 5 litre conversion
Since everyone keeps asking, i have made up a list for the wiring from the vn - vs injected 5 litre loom.if you are doing a conversion in your vl or commordore

i have done a injected 5litre conversion on my calais (originally carby v8) and done all the wiring myself. I`m am running a trimatic. But wiring is same if you run the turbo transmission. It takes a good 2 - 4 hours to do and not hard to do yourself,
just gota have some auto elec knowlodge.

If you have any question about it just send me a pm.
You will need 2 relays (4 pin) , one is a fuel pump relay and the other is a efi relay.
On a realy there are 4 pins which have nubers next to the pins, the numbers are: 85(switch power), 86(negative earth), 87(power supply direct from battery), 30(wire to item that will receive power)

black plug on the efi loom in engine bay (near battery):

Red wire:

Positive(+) power supply for injectors when ignition is switched on. Need to connect this red wire to relay pin 87 (this will be the efi relay)
a 30amp fuse (before connection to pin 30 on relay).
Connect pin 85 on relay from a ignition on power supply ( a wire that will give positive power when ignition is switched on only) , connect pin 86 on relay to earth, and connect pin 87 on relay to direct battery positive (+) power.
So relay should click on and off when ignition is turned on and off.

Violet(purple) wire:

Positive(+) power supply for fuel pump (via oil pressure switch) when ignition is switched on. Need to connect this violet wire to relay pin 87 (this will be the fuel pump relay) via a 30amp fuse (before connection to pin 30 on relay)

also you will need to connect a wire from your fuel pump (+) with this violet wire to relay pin 87 (so two wires go on the same pin on relay) as this will give power to the oil pressure switch and fuel pump when the ignition is switched on
(the computer is designed to only run the fuel pumps when there is oil pressure as a precaution and thats why the violet wire runs through the oil pressure switch) .
Connect pin 85 on relay from green with white trace wire on the black pulg( this wire that will give positive power when ignition is switched on only via the computer for one second and then cuts out until you start the engine and there is oil pressure)
, connect pin 86 on relay to earth, and connect pin 30 on relay to orange wire on black plug ( this wire goes to oil pressure switch as a direct power from battery) and also you need to join a wire direct from the battery (+) to this pin(30) on relay as well.
(so two wires go on the same pin on relay). So relay should click on and off when ignition is turned on and off via the computer.

Orange wire:

Positive (+) wire to oil pressure switch direct from battery to fuel pump relay pin 30 ( read above in violet wire)

red with black trace wire:

Positive (+) power supply for computer. Connect this red with black trace wire direct to the positive (+) battery power (countinuas power) via a 30amp fuse. No relay required. This will give continuas power to the computer.

Green with white trace:

Fuel pump switch wire from ecu to fuel pump relay pin 85 (read above in violet wire). Will give power to fuel pump relay to switch on and off.

Grey plug on efi loom in engine bay (near battery next to black plug)

bule with white wire:

Ac cooling fan relay(gives negative (-) power) (not reqiuired to hook up this wire anywhere) or you can hook up you themo`s to this wire via relay (and it will switch thermo`s on when water gets to 91c) can be altered to
different temp via computer (need software)

light green with black trace wire:

A/c relay (not required to hook up this wire anywhere) unless you are running air cond.

Blue wire:

Oil pressure light, give positive(+) power to a oil presure light in cabin. Does not need to be hook up if you dont have a oil pressure light, or you can just put a small led light on you dash and hook it uo to that.
(optional) specailly if you run a oil pressure guage.

Green (next to blue wire) wire:

Coolant tempreture signal wire, this give you a reading on you water temp guage. Best to put a aftermarket electric water temp guage with new sensor, as the vl dash guage will give you a wrong reading with the orignal sensor on the motor.
Connect this wire to you reciveing signal on you tempreture guage.

Green with black trace:

Not required.

Brown wire:

A/c switch. (not reqiured to hook up anywhere) unless you are going to connect the air cond up.

Brown with red trace wire:

Tacho signial, hook this wire up to your rpm tacho guage.

Black plug on efi loom in engine bay ( the one with 2 wires):

Purple wire:

Starter motor solinied positve (+) power supply. This wire need to be hook up to igntion starter, so when you turn the key to start it give power to the starter motor to turn over.

Brown wire:

Alternator dash light positive (+) output, this wire needs to be connected to a battery light on the dash, otherwise ti will no charge the battery if it is not hook up to a battery light.

White plug on efi loom near computer (inside car):

Brown with white trace wire:

Check engine light negative (-) power output. (must connect) connect this wire to a light somewhere on you dash to negative wire on the light and the positive wire from the light should be connected to ignition on power.

Brown with yellow trace wire:

To trip computer. (not required to hook this wire up anywhere).

Pink plug on efi loom near computer (inside car):

This plug hooks up to your transmission wiring loom if you are running the turbo transmission. If you are running a trimatic or manual here are the wires to be connected:

Yellow with white trace wire:

Trip computer. (not required to hook up any where)

grey wire:

Inhibitor switch, negative (-) power input. This wire needs to be connected to you inhibitor switch on your gear stick so the computer knows when it is in park on netural.
If the car is manual than this needs to be earthed out to negative (-) continuasly.

Grey with red trace wire:

Tourque converter clutch solinied. (not required to hook up any where if not running a four speed transmission)

pink (next to grey with red trace wire) wire:

Anti theft circuit. Need to connect this wire to positive (+) ignition on, otherwise it will no run the computer, this wire can be hooked up to your immobiliser realy so the car will not
start unless this wire gets a positive power supply.

Light blue wire:

Auto transmission tempreture switch/ 4th gear. (not required to hook up any where if not running a four speed transmission).

This is all thats needed to do and the car will start.

--------------------------

good write up man, just wanna add three things to this thread off the top of my head.

pin 30 on a relay is the supply and pin 87 is the load. although it will still work the otherway around as they are just a set of contacts, the standard for wiring a relay is pin 30 supply and 87 load. This will make problem diagnosis easier down the track.

It also says to put a fuse in between the relay and the load, this doesnt completly protect the circuit. The fuse should be the first thing in the circuit from the battery to pin 30, that way all the wiring from the battery to the relay and all the way to the load is protected.

Last thing is the oil pressure switch doesnt inhibit fuel pump operation in the event of oil preassure loss. it is there incase the fuel pump relay becomes faulty, the engine can be cranked and when oil preasure is raised, the switch closes and runs the pumps.

To test this, unplug the oil pressure switch and it will still start and run fine. Or disconnect the fuel pump relay and crank the motor, when the oil pressure light turns off the fuel pumps will turn on and engine will start.

--------------------------

hey all.i have folowed this wiring diagram.

my car cranks over now.
i have problems with this part it doesnt work unles you bridge the violet wire mentioned up the start of this diagram.it cranks over with the pink wire hooked up but fuel pump only works when you bridge it to pink wire and now fuel pump primes constantly.how do i get it to work normaly?

pink (next to grey with red trace wire) wire:

Anti theft circuit. Need to connect this wire to positive (+) ignition on, otherwise it will no run the computer, this wire can be hooked up to your immobiliser realy so the car will not
start unless this wire gets a positive power supply."

After testing the computer for IGNITION/power on B1, A6 and C16 successfully and hearing my fuel pump prime, my engine warning/oil pressure lights shine I thought I was onto a winner..

Tested for pulse at injectors with noid light with no success.. Test power on coil with a test light with power on ignition it shines, but crank and nothing. Im also not getting any fuel delivery what so ever.. The above FUEL PUMP relay clicks and definately primes the pump on ignition...

Im quite sure I dont have spark, Ill get my spark tester tomorrow and double check..

Whats going on guys????

Model: 
Engine: 
Section: 

Comments

The summary is.

Power to computer
No ignition pulse
No spark
No fuel - Fuel pump primes on ignition.

Plenty of compression on a rebuild motor.

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

is the o44 pump in the tank as it is a pressure pump not a pick up pump !
the pump sould prime every minute or so!
i used 040 pick up & 044 pressure
cheers joe

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Cheers Joe

My fuel pump is definitely an in-line pressure pump.

Have you got any more information regards to relays and power supply for the pump?

Any help mate

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

"is the o44 pump in the tank as it is a pressure pump not a pick up pump !
the pump sould prime every minute or so!
i used 040 pick up & 044 pressure
cheers joe"

The pump is definitely an in-line pressure pump

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

I have reason to believe my loose HALL EFFECT sensor on the dizzy is the main culprit.

Am I right in saying that the dizzy sensor provides signal for injectors (explains lack of pulse).
Could this also be cause of loss of fuel pump or is this an immobilisor problem?

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

u said in post no fuel at all, is the 044 (inline pressure pump) mounted above the tank,if so it will not pick up fuel.
044 pumps are good for 600+ hp u will need a regulator. i would use a 040 pump(vl pump)as it will pick up & pressure.
the pump priming on & off is normal with efi (not a holley blue for a carb)
as for spark dont no? tryin to help with what i know!
cheers joe

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Cheers Joe

The 040 is an in-tank positive displacement pressure pump. Unless you are running mega horsepower there is no need to run another external pump. The VL pump is last three digits 070 and is an external positive displacement pump. This is also a pressure pump but could be used to fill a surge tank that is feeding an 044 pump. There is a file containing all these pump details in my shed

http://gallery.oldho...

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

[http://gallery.oldho...|My EH Holden Shed]

 Email Me

just checked in boot & myeh your right i have a 070 feeding my 044
cheers joe

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Cheers Joe

hi everyone im looking for info on my project its one that has been done many times before me! im putting a 5.0ltr 304inj in my hz gts monaro im wanting to know what fuel pump is best suited for my conversion as i still got the factory tank in the hz . i was thinking of going with external surge tank possible???? and electric pump as of witch one i was hoping someone could give me some info thats been tried and tested and any thing that is relevant and save me any hiccups

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

"u said in post no fuel at all, is the 044 (inline pressure pump) mounted above the tank,if so it will not pick up fuel.
044 pumps are good for 600+ hp u will need a regulator. i would use a 040 pump(vl pump)as it will pick up & pressure.
the pump priming on & off is normal with efi (not a holley blue for a carb)
as for spark dont no? tryin to help with what i know!
cheers joe"

----------------------

Ok

So i disconnected my fuel pump + wire and connected a long wire straight to battery.. YAY I got fuel delivery into container. Now I need to find out if my FUEL PUMP RELAY wiring is incorrect, or if it simply requires a good hall effect signal for the fuel pump to receive this power source!

RELAY WIRING as follows

30 - Battery (30amp fuse), Also connected to orange wire (positive to oil pressure switch).
86 - Ground (decent)
85 - Connected to Green/White wire (Ignition power via computer for a second).
87 - Connected to + on fuel pump and to Violet wire (oil pressure feed).

How exactly should I mount the fuel pump below the HQ fuel tank?? Currently it is mounted above the tank. How should the fuel lines be routed?

Cheers

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

ill have a look at a mates lj 304 on sunday arvo & check relay
let u no
cheers joe

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Cheers Joe

mate that would be great!!!

Could you check out his fuel pump situation/positioning also

life saver!

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Ive sorted out the fuel pump location so fuel issues are good! Good power and earth at pump..

Got a new dizzy and ignition module. Still have no spark or pulse at injectors.

I tested coil + with test light and it shines on ignition but doesnt light up while cranking. I thought it should? Im getting 12v to coil too..

Ill test coil tomorrow and see if its buggered.!!!

I need spark, but where is my injector pulse!!!!

EFI relay must be the problem???

anyone

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

coil has only 7k ohms.. buggered..

should I have earth at the coil all the time or when cranking or does the ignition module earth it out??

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Do I give ignition power or crank ignition power to the pink anti-theft wire??

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

No ignition pulse or spark

[b]Since connecting pink anti-theft A6 wire to cranking ignition I have lost fuel pump priming, engine light on ignition and I still havn't got any pulse/spark.[/b]

My fuel pump used to prime when i connected the above to standard ignition power and my engine light used to come on with ignition. Now it only flashes when I crank.. WHAT THE [Naughty Pottyword] IS WRONG. argh its a dead end.

EFI RELAY
30 - Battery (30amp fuse) also connected to C16/B1 on ECU plug
86 - Ground
85 - Ignition cranking power, A6 PINK ANTI THEFT WIRE, Pink wire ALDL connector
87 - Ignition module, Ignition coil +, Injectors

FUEL PUMP RELAY
30 - Battery (30amp fuse), Also connected to orange wire (positive to oil pressure switch).
86 - Ground (decent)
85 - Connected to Green/White wire (Ignition power via computer for a second).
87 - Connected to + on fuel pump and to Violet wire (oil pressure feed) and violet wire in ALDL plug.

ENGINE LIGHT
Ignition on one side of the globe and brown/white wire in ECM plug on other side of the globe.

Fuel doesn't prime on ignition, engine light doesn't come on when in ignition position. No spark, injector pulse while cranking even with [b]new coil, dizzy and ignition module[/b]...

HAS TO BE WIRING ISSUE.!!

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Mmm long story i make i make it short:
Brought a VR 304 auto and the vats are turned off,drove the VR trough Australia took the engine gearbox loom and and and out of the VR shipped it home to Holland...

I will get the engine this week at home,and i wanne put it my Opel Monza (Commo VB coupe).

But the loom in the description is a bit diffent than mine i have 3 plugs:a grey and black and i dont have a orange wire....

What are the diffence between a VN-VP loom compared to a VR-VS loom..

Hope somebody can help me.

Greetz Ben

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

the orange wire runs directly from the oil pressure switch plug.

follow it back to the grey plug

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Ok so I bridged the pink/yellow wires on the switch and I'm still not getting injector pulse or spark. There is 12v at coil positive.

The ignition module is a reconditioned unit and is only 2-3 weeks old. When the key is on ignition my test light glows at my ignition coil positive terminal. Which it shouldn't. The light should flicker on crank, but it doesn't.???

My efi relay has ignition power, a good earth and battery source.

How can I test my dizzy hall effect sensor and ignition module to rule them out??? Coil is 2 weeks old.

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

anyone?

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

hi mate not able to help mates torrie wires are covered up.
try a new post as this is a bit old
myeh sould know the answer. best of luck
cheers joe

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Cheers Joe

http://oldholden.com...

Ok done some testing
Coil doesn't have a constant earth - GOOD
Coil has 12v and so does the Ignition module - GOOD
Tested EFI relay as per manual and it all checks out (continuity etc) - GOOD
Tried my ignition module on a mates 5L and it worked just fine - GOOD

Went to test the signal wire on the hall effect sensor and it remains (0L infinite ohms) even while cranking. Dizzy is currently at EFI shop for testing as it was a new unit. Ill hear back from them. Is there anything else that can affect the signal/pulse from the hall effect?

Ive noticed that the black wire on my hall effect lines up with the red wire on my dizzy plug. Check the wiring diagram and this appears to be correct. - GOOD

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

As for ECM partnumbers

MEMCAL - DELCO ASBX 9285 (US PAT 4,702,706) - Blue in colour

ECM -
Service number - 16183082
P/N - SL1001
* 16183082623 *

I think mine is a VR!!!!! which would explain no pulse/spark. Bastard told me it was 100% a VN ECM.

93-95 VR Commodore 3.8 V6 (man) GMH 16183082/16206305
93-95 VR Comm/Stat 5.0 v8 (man) GMH 16183082/16206305
93-95 VR Comm/Stat V8 180kw(man) GMH 16183082/16206305
93-95 VR Utility 3.8 V6 (man) GMH 16183082/16206305
93-95 VR Utility 5.0 V8 (man) GMH 16183082/16206305
95-98 VS Commodore 3.8 v6 (man) GMH 16183082/16206305
95-98 VS Comm/Stat 5.0 High Perf(man)GMH 16183082/16206305
95-98 VS Utility 3.8 V6 (man) GMH 16183082/16206305
95-98 VS Utility 5.0 V8 (man) GMH 16183082/16206305
98- VT Commodore 3.8 V6 (man) GMH 16183082/1620630

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Is there a difference between the wiring of the hall effect sensor plug on VN and VR??

Does the red wire in the hall effect + line up with the black/white wire on the plug??

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

I have power at ignition feeds D15 and D16 then I fixed the ignition/cranking power situation and now have 12v while cranking and ignition.. Well it's 10ish while cranking.

So far NO DEAL..

Still don't have spark or pulse!!.
Checked for codes got one flash followed by 2 flashes. -- 12 No spark pulses at CPU or else good system, no codes

Can someone explain how to test the spark pulse situation at the ECM ?? Because I corrected the injectors at the ECM side when I reconnected the blue wires.

I will replace the 4 wires going from ignition module to ECU.

Anyone?

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Wat wires do i need to connect in the white 9 pin conector near the ecu

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

I had my 5 litre running but then I unplugged the dash to see if it would run without the dash but it didn't so I plugged everything back in and it wouldn't start I just don't have injecter pouse and I didn't have a key what should I try and what wires do I really need to keep it running

  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.

Add new comment

Filtered HTML

  • Allowed HTML tags: <a> <strike> <blink> <i> <u> <br> <b>
  • Filtered words will be replaced with the filtered version of the word.
  • Lines and paragraphs break automatically.
  • Web page addresses and e-mail addresses turn into links automatically.

Plain text

  • Allowed HTML tags: <a> <em> <strong> <cite> <blockquote> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • No HTML tags allowed.
  • Filtered words will be replaced with the filtered version of the word.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs break automatically.
Comment attachments
Files must be less than 100 MB.
Allowed file types: jpg jpeg gif png txt pdf bmp mov mp4 mp3 avi.
CAPTCHA
This question is used to make sure you are a human visitor and to prevent spam submissions. Email rusty@oldholden.com if you have a problem.
  • Like0
  • no like0
  • Holdenpaedia idea0
  • Funny0
  • Wrong Category0
Please use, Holdenpaedia will get the first box on the left side. Post any suggestions.